Einführung in den Namensmanager

In diesem Beitrag möchte ich Dir den Namensmanager vorstellen. Du findest diese Funktion im Menüband unter "Formeln". In Excel kann einem Bereich ein Name gegeben und zu einem späteren Zeitpunkt kann darauf zugegriffen werden. Als einfaches Beispiel: Wir können mittels Formel eine Summe bilden. Die Formel dazu lautet:

=SUMME(A2:A6)

Markierst Du nun den Bereich A2 bis A6, kannst Du im Namenfeld, wo "A2" steht, einfach einen Namen reinschreiben und mit Enter bestätigen. Im Bild unten siehst Du das Namenfeld. Wichtig zu beachten ist, dass Du bei der Namensgebung keine Leerschläge oder Sonderzeichen verwenden darfst. Zahlen hingegen sind erlaubt. Anstatt im Namenfeld den Namen einzugeben, gelangst Du im Menüband via "Formeln" → "Namen definieren" zum gleichen Ziel.

Namensfeld

Wenn Du nun erneut die Summe bilden möchtest, kannst Du direkt mit der Eingabe von "=SUMME(" beginnen und Dich dann auf Deinen definierten Namen beziehen. Dieser ist nun stellvertretend für den Bereich A2 bis A6. Du findest Deinen Namen auch in der Liste mit den Formeln, allerdings mit einem anderen Kennzeichen vornedran:

VerwendungInFormel

Anpassungen an bestehenden Namen

Um im Nachhinein den definierten Bereich anzupassen oder zu erweitern, kannst Du via "Formeln" auf "Namensmanager" klicken. Dies könnte der Fall sein, wenn Du weitere Daten in Deiner Excel-Tabelle erfasst hast. Im Namensmanager findest Du sämtliche definierten Namen:

Namensmanager

Falls Du Anpassungen vornehmen musst, weil Du beispielsweise weitere Zahlenwerte eingetragen hast, kannst Du den Bereich unter "Bearbeiten..." neu kennzeichnen. Eine schnellere Variante besteht darin, im unteren Bildrand bei "Bezieht sich auf:" einfach die Zahl von "...$A$6" durch den neuen Zeilenindex (beispielsweise 10) zu ersetzen.

Es gibt natürlich weitere Möglichkeiten, wo die Definition von Namen hilfreich ist. Du kannst Dir damit sogenannte Dropdown-Listen erstellen, damit aus einer Liste nur vorgegebene Werte ausgewählt werden können. Das Erweitern des Bereiches im Falle von neuen Zahlenwerten gemäss dem Beispiel oben kann umgangen werden, wenn Du den Bezug mit der Formel "BEREICH.VERSCHIEBEN" dynamisch machst. Dadurch wird Dein Name automatisch um die neuen Werte ergänzt. Dieser komplexeren Formel sowie den Dropdown-Listen möchte ich jedoch eigene Beiträge widmen.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.