Vereinfachter (S-)Verweis - Anwendung der Formel XVERWEIS

Die Formel "SVERWEIS" ist eine der bekanntesten in Excel - da sie mächtige Überprüfungen durchführen und Ergebnisse liefern kann, aber eben auch manch einem Benutzer Probleme bereitet. Diverse Angaben und Regeln müssen erfüllt werden, damit man zum gewünschten Resultat gelangt. Ein Nachteil der Formel ist zudem, dass die Ergebnisspalte rechts von dem Suchwert stehen muss (siehe hierzu eine ebenfalls valide Lösung SVERWEIS nach links).

In diesem Beitrag wird eine neuere Formel "XVERWEIS" vorgestellt. Diese Funktion ist deutlich intuitiver, wie die ersten drei Argumente der Syntax zeigen (nur diese drei sind notwendig, die Angaben in den eckigen Klammern können ignoriert werden):

XVERWEISSyntax

Die erste Angabe verlangt analog dem SVERWEIS ein Suchkriterium - nach welchem Wert soll gesucht werden? Die Suchmatrix ist z.B. die Spalte, in welcher das Suchkriterium steht. Beim SVERWEIS wird es bereits an dieser Stelle kompliziert, da die Matrix sowohl das Suchkriterium wie auch das Resultat enthalten muss. In dieser Formel ist das dritte Argument die Rückgabematrix (z.B. die Spalte, in der das Resultat steht). Wie erwähnt hat die Formel drei weitere Argumente in eckigen Klammern - diese sind fakultativ und bieten weitere Möglichkeiten, auf die wir hier nicht eingehen.

Schauen wir uns ein konkretes und simples Beispiel an. Eine Tabelle enthält die Regionalleiter und deren E-Mail-Adressen. In Spalte F suchen wir nach der Region, um die E-Mail zu erhalten:

XVERWEISSpalten1

Wechseln wir das Suchkriterium von "Nordeuropa" zu "Nordamerika", erhalten wir die entsprechende E-Mail-Adresse.

XVERWEISSpalten2

Dies ist die effektive Formel in der Zelle "G3":

=XVERWEIS(F3;B3:B8;D3:D8)

Selbstverständlich könnte man auch hier Werte "absolut" setzen (Dollarzeichen), damit man die Formel vereinfacht kopieren könnte - hier wird allerdings nur ein einziger Wert gesucht.

Beachte zudem: Mit der Formel ist nicht nur der "SVERWEIS" (Spalten) möglich, sondern auch der "waagrechte" Verweis (WVERWEIS). Die oben aufgeführte Tabelle habe ich transponiert, um den XVERWEIS auf ein solches Format anzuwenden. Unten wird die "gedrehte" (transponierte) Tabelle sowie die angepasste XVERWEIS-Formel dargestellt. Um die Abbildung übersichtlicher zu gestalten, habe ich gewisse Spalten (D bis G) gruppiert und ausgeblendet.

XVERWEISZeilen1

Die Formel in Zelle "C7" lautet:

=XVERWEIS(B7;C2:H2;C4:H4)

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.